HDOJ1385——最短路字典序输出路径

HDOJ1385——最短路字典序输出路径

Problem Description

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.

要从城市A到城市B,中途走的高速公路要收高速费,途径城市要收过路费。求怎么规划路线花费最少。若有多解,输出字典序最短小的路径。

Input

First is N, number of cities. N = 0 indicates the end of input. The data of path cost, city tax, source and destination cities are given in the input, which is of the form: a11 a12 … a1N a21 a22 … a2N …………… aN1 aN2 … aNN b1 b2 … bN c d e f … g h where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, …, and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

Output

From c to d : Path: c–>c1–>……–>ck–>d Total cost : …… …… From e to f : Path: e–>e1–>……….–>ek–>f Total cost : …… Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output

From 1 to 3 :
Path: 1–>5–>4–>3
Total cost : 21

From 3 to 5 :
Path: 3–>4–>5
Total cost : 16

From 2 to 4 :
Path: 2–>1–>5–>4
Total cost : 17


问题分析

本来用dij做的,结果无限WA。。用dij处理字典序的想法是把某个节点的路径全部拉出来然后比较。这里先放上我WA的代码。

#include<iostream>
#include<cstring>
using namespace std;
const int inf = 0x3f3f3f3f;
const int N = 550;
int n,m,mat[N][N];
int d[N],p[N],vis[N],tax[N];
//bool flag = true;
int step;

void dfs(char *str,int node)  //顺序打印路径
{
  if(node == -1) return;
  dfs(str,p[node]);
  str[step++] = node + '0';
}

bool cmp(int a,int b)
{
  char sa[N],sb[N];
  step = 0;
  dfs(sa,a);
  sa[step++] = b + '0';
  sa[step] = 0;
  step = 0;
  dfs(sb,b);
  sb[step] = 0;
  step = 0;
  if(strcmp(sa,sb) < 0) return true;
  else return false;
}

void print(char *route,int s,int t)
{
  /*
  if(flag)  flag = false;
  else cout << endl;
  */
  cout << "From " << s << " to " << t << " :" << "\nPath: ";
  for(int i=0;route[i] !='\0';i++)
  {
    if(i == 0)  cout << route[i];
    else cout << "-->" << route[i];
  }
  cout << "\nTotal cost : " << d[t] << endl;
  cout << endl;
}

void init()
{
  for(int i=0;i<N;i++)
  {
    d[i] = inf;
    p[i] = -1;
    vis[i] = 0;
  }
}
void dijkstra(int s,int t)
{
  init();
  d[s] = 0;
  for(int i=1;i<=n;i++)
  {
    int minn = inf;
    int node = -1;
    for(int j=1;j<=n;j++)
    {
      if(!vis[j] && d[j] < minn)
      {
        minn = d[j];
        node = j;
      }
    }
    if(node == -1)  break;
    vis[node] = 1;
    for(int j=1;j<=n;j++)
    {
      if(!vis[j] && mat[node][j] != inf)
      {
        if((mat[node][j] + d[node] + (j!=s&&j!=t)*(tax[j])) < d[j])
        {
          d[j] = mat[node][j] + d[node] + (j!=s&&j!=t)*(tax[j]);
          p[j] = node;
        }
        else if((mat[node][j] + d[node] + (j!=s&&j!=t)*(tax[j])) == d[j] && cmp(node,j))  //字典序
        {
          p[j] = node;
        }
      }
    }
  }
  char route[N];
  step = 0;
  dfs(route,t);
  route[step] = 0;
  print(route,s,t);
}

int main()
{
  int s,t,tmp;
  while(cin >> n && n)
  {
    //flag = true;
    for(int i=1;i<=n;i++)
      for(int j=1;j<=n;j++)
        {
          cin >> tmp;
          mat[i][j] = (tmp == -1) ? inf : tmp;
        }
    for(int i=1;i<=n;i++) cin >> tax[i];
    while(cin >> s >> t && (s != -1 && t != -1))
    {
      dijkstra(s,t);
    }
  }
}

这道题实际上用Floyd会非常方便。

#include<iostream>
#include<cstring>
using namespace std;
const int inf = 0x3f3f3f3f;
const int N = 200;
int n,m,tax[N],mat[N][N],path[N][N];

void init()
{
  for(int i=0;i<=n;i++)
    for(int j=0;j<=n;j++)
      path[i][j] = j;
}


void floyd()
{
  for(int k=1;k<=n;k++)
  for(int i=1;i<=n;i++)
  for(int j=1;j<=n;j++)
  {
    if(mat[i][k] != inf && mat[k][j] != inf)
    {
      if((mat[i][k] + mat[k][j] + tax[k]) < mat[i][j])
      {
        mat[i][j] = mat[i][k] + mat[k][j] + tax[k];
        path[i][j] = path[i][k];
      }
      else if((mat[i][k] + mat[k][j] + tax[k]) == mat[i][j] && (path[i][k] < path[i][j]))  
        path[i][j] = path[i][k];
    }
  }
}

int main()
{
  int s,t,tmp;
  while(cin>>n && n)
  {
    for(int i=1;i<=n;i++)
    {
      for(int j=1;j<=n;j++)
      {
        cin >> tmp;
        mat[i][j] = (tmp == -1) ? inf : tmp;
      }
    }
    for(int i=1;i<=n;i++) cin >> tax[i];
    init();
    floyd();
    while(cin >> s >> t && (s != -1 && t != -1))
    {
      cout << "From " << s << " to " << t << " :\nPath: ";
      tmp = s;
      while(tmp != t)
      {
        cout << tmp << "-->";
        tmp = path[tmp][t];
      }
      cout << tmp << endl;
      cout << "Total cost : " << mat[s][t] << "\n" << endl;
    }
  }
}
... ... ...